1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Roof ECU

Discussion in 'Problems, Fixes, Tips...' started by Ianred, Apr 10, 2013.

  1. Ianred

    Ianred Copenworld Newbie

    Joined:
    Apr 3, 2013
    Car(s):
    Bmw e30
    Bwm e36
    Hi, Has anyone on here had their roof ecu repaired / tested and if so can you recommend someone who can do this? I'm looking at my friends Copen and the red light on the dash is permanently on and none of the boot/ roof works at all. I've tested the locks / hydraulics and they are all fine and i have also tested the micro switches ( where i can ) but there was moisture in the boot so i suspect the ECU. There seem to be a no of firms offering ECU repairs / testing on the web and i would rather use someone who's been used by forum members before?
    The bits i can't test are the magnetic switches in the hinges are they a common fail ?

    Thanks
     
  2. Klausanta

    Klausanta Copenworld Member

    Joined:
    Sep 27, 2012
    Location:
    Surrey
    Car(s):
    Renault Megane
    Hi

    I had a leaking/wet boot (in fact totally full of water) and I have still got on-going issues with the red light staying on all the time although my problem is intermittent and for the last few days (fingers crossed) the roof has been working properly again.

    http://www.copenworld.com/vb3/showthread.php?t=1511&page=2

    My ECU was soaked but when I removed it to check there were no physical signs of damage or corrosion.

    Other people have posted to say that they have experienced strange problems until they dried the boot out completely and then things started working again.

    http://www.copenworld.com/vb3/showthread.php?t=1389

    There were recently a couple of ECU's for sale on eBay but when I eventually decided to purchase one they had gone although I am still not convinced that the ECU is actually the problem.

    Strange, but I originally put my problem down to the luggage door closer switch - the magnetic switch you mention as part of it on mine was broken.

    http://www.copenworld.com/vb3/showthread.php?t=1104&page=2

    Why not try drying the boot out first?

    Hope this all helps

    KS
     
  3. dwayner

    dwayner Copenworld Regular

    Joined:
    May 12, 2011
    Location:
    Mornington Peninsula
    Car(s):
    A 2005 copen and a
    Camry Sportivo
    dwaner

    i think im having ths same problem. I covrtrd the car with a plastic cover, while i went away, and we had a week of rain, and i got a lot of water in the boot - a puddle formed near the back, and the condensation formed through out the boot. the roof light stayed on in the dash the whole time p but when in dried out, it now works, and hasnt happened since.
     
data-ad-format="auto">

Share This Page