1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

my radio

Discussion in 'Problems, Fixes, Tips...' started by ian, Aug 23, 2012.

  1. ian

    ian Copenworld Newbie

    Joined:
    Aug 21, 2012
    Location:
    billericary
    Car(s):
    one
    Hi can some one help me !! My radio was turned up full blast very quickley and now not working right


    can just hear some music but cant get it louder whats happend is it my speakers.???
     
  2. terry urwin

    terry urwin Copenworld Newbie

    Joined:
    Jul 27, 2012
    Location:
    consett
    Car(s):
    yes vivid
    hi sounds like you have blown the power amp stage is only using the pre amp thats why its very quiet ( tip if you desconect the speaker wires and put a battery across the terminals 1.5 volt the speakers will move forward or back this tip can be used to check the polaraty of the speakers + side speaker out hope this helps
     
  3. ian

    ian Copenworld Newbie

    Joined:
    Aug 21, 2012
    Location:
    billericary
    Car(s):
    one
    Thanks terry i will try that. what will this do when i do that . will i need new speekers or fuse sorry no car sence .
     
  4. terry urwin

    terry urwin Copenworld Newbie

    Joined:
    Jul 27, 2012
    Location:
    consett
    Car(s):
    yes vivid
    hi if your speakers move forwards and back when you change the wires over on the 1.5volt battery the speakers are ok and its the radio at fault(good time to upgrade your sound system good luck......
     
  5. ian

    ian Copenworld Newbie

    Joined:
    Aug 21, 2012
    Location:
    billericary
    Car(s):
    one
    Thanks will try that.
     
data-ad-format="auto">

Share This Page