1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Horn not working ;(

Discussion in 'Problems, Fixes, Tips...' started by Chrishome49, May 15, 2014.

  1. Chrishome49

    Chrishome49 Copenworld Newbie

    Joined:
    Sep 18, 2013
    Car(s):
    Daihatsu Copen, 2003, silver
    Hi there,
    I'm loving my wee Copen, especially in the sunshine. The horn has stopped working, there appears to be a small click when I press it from the steering wheel but the horn doesn't sound. Any advice would really be appreciated.
    Many thanks.

    Chris
     
  2. Adam K

    Adam K Copenworld Guru

    Joined:
    Oct 27, 2010
    Location:
    Worcester, UK
    Car(s):
    Nissan Cube Kaizen
    The electrical contacts at the horns will have corroded.
    Take the grill off & find the horns on the bottom right. Try to clean up the electrical contacts with a tooth brush or wire wool. You may need to buy new horns if the electrical contact tabs are fragile from corrosion (on ebay). You will most likely also need to replace the crimps on the harness as they are corroded.

    On my car I replaced the horns & the crimps on the harness.

    They are well placed on the car to get covered in salt spray during the winter.
     
  3. speedy-g

    speedy-g Copenworld Member

    Joined:
    Mar 25, 2014
    Location:
    Kent
    Car(s):
    Copen Turbo
    Vectra SRI 2.6 V6
    Looking for Jaguar XJR V8
    Fix

    The male tabs snapped off on mine when i tried to fix the horns so I cut the wires and soldered them to the round copper rivets.
     
data-ad-format="auto">

Share This Page